CANADREAM V2.4 MAP


CANADREAM V2.4 MAP

Coast 2 Coast 2.3 minimum is REQUIRED for playing or game crash

Priority:
1-CanaDream 2.4
2-Coast 2 Coast 2.3
2.4

* compatible ATS 1.29
* compatible C2C 2.3
* add yarmouth
* background world map temporaly removed, back in version 2.5


Credits
ManiaX
1 Star2 Stars3 Stars4 Stars5 Stars (4 votes, average: 5.00 out of 5)
Loading...

What is this mod use for

ATS Mods will help you to add any kind of features you want to your ATS game. Each ATS mod has different specifications, therefore it’s important to read descriptions carefully. This will help you to get the exact American Truck Simulator Mod you are looking for. If you want to become one of the most successful players, you simply must take every opportunity and play smart. It has never been so easy to upgrade your game and personalize it, so try it right now!



You may also like...

1 Response

  1. SortingHat says:

    For some odd reason Railworks DOES NOT have this problem. I can still play all my routes. There is no need for London to Brighton V2.X whatever route patch to download. Your routes just work.

Leave a Reply

Your email address will not be published. Required fields are marked *